AutoCad Tutorials                                                                                   Lesson 1 – Setting up Environment
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AutoCAD for Naval Architects

Step by Step Tutorials

Lesson 1

“Setting up Environment”

1. Start from Scratch:
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· When you load ACAD2000 or any other previous version, a startup dialog appears waiting for your orders as shown in the next figure

· In this dialog you have to choose one of the four options

· Open a drawing:

 To print or edit an existing file

·  Start from Scratch

To start new file with ACAD default settings

· Use a Template:

To start new file with Special settings

· Use a Wizard:

To start a new file with your own settings by the help of ACAD wizard (Advanced or Quick)

· If you don’t want to choose any of the above options, you can simply press Cancel to start the default ACAD Metric settings and you can adjust your settings after a new file is created.

2. Setting the Drawing Environment:

1. First of all we’ll adjust the units by selecting Format>Units

2. In the units dialog box be sure to select decimal in the length type, 0.0 in the precision, then press ok

3. Notice the mouse counter at the most left bottom of the CAD screen, it’s now have the new precision

Hint: you can also display the Units dialog box by typing units in the command line
4. Now let’s set our drawing limits by selecting Units Format>Drawing limits.

5.  A prompt at the command line asks you to specify the lower left corner, type 0,0 in the command line and then press ENTER.

6.  Another prompt for the upper right corner; type in 70, 50 as our answer to the command prompt. These are the dimensions of a usual drawing sheet in cm.

Hints:

1. You can also display the Drawing limits Command by typing limits in the command line

2. If we plot our drawing using 1 drawing units = 10 mm, the drawing scale would be 1:1 – to see the boundaries of your drawing space draw a rectangle with lower left corner 0,0 and upper right one 70,50

7. Finally in order to see your drawing limits, press the zoom all button in the zoom fly out located in the standard toolbar, or simply you can type zoom then all in the command line

3. Setting the Tool Bars:

· As we noticed a command is given to ACAD by either writing it in the command line or pressing on its icon on a certain toolbar and this is certainly much easier.

· There are so many toolbars in ACAD and if we show them all, there won’t be enough room for the drawing area, nevertheless be sure that the ACAD window have these important toolbars:

Draw – Modify – Object Snap – Object Properties – Standard - Modify II

4. The Status Bar:
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· The first box on the left shows the coordinates of the point at which the mouse is located.

· To show the function of the other buttons right-click any of them, choose Settings from the menu that appears, the Drafting Settings dialog bow is then appeared
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· The grid is a pattern of dots that extends over the area specified by the limits. Using the grid is similar to placing a sheet of grid paper under a drawing. The grid helps you align objects and visualize the distances between them. You can turn the grid on and off in the middle of another command. The grid is not displayed in the plotted drawing. 

· If you zoom in or out of your drawing, you might need to adjust grid spacing to be more appropriate for the new magnification.

To turn on the grid and set grid spacing

1. From the Tools menu, choose Drafting Settings.

2. On the Snap and Grid tab of the Drafting Settings dialog box, select Grid On. 

3. Enter the value for Grid X Spacing in units.

4. To use the same value for vertical grid spacing, press ENTER. Otherwise, enter a new value for Grid Y Spacing. 

5. Choose OK.

To turn the grid on or off, click Grid on the status bar, use the GRID command, press CTRL+G, or press F7.

· Snap mode restricts the movement of the crosshairs to intervals that you have defined. When Snap is on, the cursor seems to adhere, or “snap,” to an invisible grid. Snap is useful for specifying precise points with the keyboard or pointing device. You control snap precision by setting the X and Y spacing. Snap has a toggle control and can be turned on or off during another command. 

· Snap spacing does not have to match grid spacing. For example, you might set a wide grid spacing to be used as a reference but maintain a closer snap spacing for accuracy in specifying points. You also can set the grid spacing to be smaller than the snap spacing.
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To turn on Snap mode and set snap spacing

1. From the Tools menu, choose Drafting Settings.

2. On the Snap and Grid tab of the Drafting Settings dialog box, select Snap On.

3. Enter the value for Snap X Spacing in units. 

4. To specify the same vertical snap spacing, press ENTER. Otherwise, enter the value for Snap Y Spacing.

5. Under Snap Style & Type, select Rectangular Snap and Grid Snap. (For information about isometric and polar snap options, see “Using Snap Mode with Polar Tracking,” and “Setting Snap and Grid to Isometric Mode.”)

6. Choose OK.

To turn Snap mode on and off, click Snap on the status bar, use the SNAP command, press CTRL+B, or press F9.

5. Working with Layouts:

· After you complete a drawing model, you can begin creating a layout to plot by choosing a layout tab. When you choose a layout tab for the first time in a drawing session, a single viewport is displayed, and a sheet with margins indicates the paper size of the currently configured plotter and printable area of the paper. AutoCAD displays the Page Setup dialog box, in which you specify layout and plot device settings. Setting the plot settings and using Preview, you can visualize the resulting layout without actually plotting. The layout settings you specify are stored with the layout. 

· If you don't want the Page Setup dialog box to be displayed each time you begin a new drawing layout, you can clear Show Page Setup Dialog for New Layouts on the Display tab in the Options dialog box. If you don't want AutoCAD to automatically create a viewport for each new layout, you can clear Create Viewport in New Layouts on the Display tab in the Options dialog box.

· Once you've created a layout, you can delete, rename, move, or copy the layout by right-clicking the layout tab, and then choosing an option from the shortcut menu. 

To switch from model space to a layout

1. After creating a drawing in model space, choose the Layout1 tab.

2. A single viewport containing the model drawing is displayed. The Page Setup dialog box is also displayed, in which you can specify a plotter and page setup.

To set up the plotting environment

1. From the File menu, choose Page Setup.

2. In the Page Setup dialog box, enter a name for the layout you are preparing for plotting.

· To rename a layout, right-click the layout tab, and then choose Rename from the shortcut menu. You can also change the name of a layout in the Page Setup dialog box.

3. To name and save the current page setup, choose Add to display the User Defined Page Setups dialog.

4. On the Plot Device tab, verify the configured plotter name, or select a plotter from the list of currently configured plotters.

5. To view or modify the plotter configuration information, choose Properties.

· The Plotter Configuration Editor is displayed. 

6. To apply a plot style table to the layout, select a table from the Plot Style Table list.

7. To view or modify the plot styles associated with the attached plot style table, choose Edit.

· The Plot Style Table Editor is displayed.

8. To add a new plot style table, choose New. 

· The Plot Style Table wizard is displayed, in which you can create a new plot style table.

9. Choose OK. The layout settings you have specified are applied to the current layout.

10. To plot the current layout with the settings you have specified, choose Plot.

NOTE: To display the plot styles you have applied to an object, select Display Plot Styles, choose OK, and then enter regen on the command line

6. Modifying the AutoCad Environment:

· You can change many AutoCAD window and drawing environment settings in the Options dialog box. For example, you can change how often AutoCAD automatically saves a drawing to a temporary file, and you can link AutoCAD to directories containing files you use frequently. Experiment with different AutoCAD environment settings until you create the drawing environment that best fits your needs.
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· Files:

"Specifying Search Paths, File Names, and File Locations." 

· Display: 

"Configuring the AutoCAD Display."

· Open and Save: 

"Opening and Saving Your Drawings."

· Plotting:

"Controlling Plotting Properties."

· System:

"Configuring System Options."

· User Preferences:

"Setting User Preferences."

· Drafting:

"Setting Drafting Properties."

· Selection:

"Changing Selection Options."

· Profiles:

"Creating Profiles."

· You can use the Profiles tab in the Options dialog box to create and save your drawing environment settings as a profile. If you share your workstation with other users who use the same login name, you can restore your options by making the profile current. You can also create and save profiles to use with different projects. By default, AutoCAD stores your current options in a profile named UNNAMED PROFILE. AutoCAD displays the current profile name, as well as the current drawing name, in the Options dialog box.

· To make a profile current

1. From the Tools menu, choose Options.

2. In the Options dialog box, choose the Profiles tab.

3. On the Profiles tab, select the profile you want to make current.

4. Choose Set Current. Then choose OK.

· You can also initiate a specific profile before starting AutoCAD by using a command line switch. 

· To make a profile current before starting AutoCAD

1. On the Windows desktop, right-click the AutoCAD icon to display the shortcut menu.

2. Choose Properties from the shortcut menu.

3. In the AutoCAD Properties dialog box, choose the Shortcut tab.

4. Under Target, enter /p currentprofile after the current target directory. For example, to make the profile User12 current, enter the following in Target:

"c:\acad2000\acad.exe"/p user12 

5. Choose OK to exit the dialog box. 

· The profile name you enter is the current profile each time you start AutoCAD.

7. Modifying Tool Bars:

· You can change the size of toolbar buttons and reposition, add, or delete toolbar buttons. You can also change the toolbar name and turn tooltips on and off.

To modify a toolbar:

1. From the View menu, choose Toolbars.

2. If the toolbar you want to modify is not displayed, select it in the Toolbars dialog box.

3. Choose Customize.

4. While the Customize Toolbars dialog box is displayed, you can modify any displayed toolbar as follows:

· Drag toolbar buttons right or left to reposition them.

· Create spaces by dragging a button to the right or left edge of the button beside it, but not past the middle.

· Remove toolbar buttons by dragging them off the toolbar.

· Add buttons to toolbars by dragging them from the Customize Toolbars dialog box to the toolbar. Change the Categories selection to display the buttons you want to add.

· Drag buttons from one toolbar to another, or press CTRL while you drag to copy the toolbar button to another toolbar.

5. Choose Close to exit the dialog boxes.

To rename a toolbar:

1. From the View menu, choose Toolbars.

2. In the Toolbars dialog box, select the toolbar name, and then choose Properties.

3. In the Toolbar Properties dialog box, enter a new name.

4. To change the text displayed on the status line, enter new text at Help, and then choose Apply.

5. In the Toolbars dialog box, choose Close.

To change the size of buttons

1. From the View menu, choose Toolbars.

2. In the Toolbars dialog box, select Large Buttons and choose Close.

To display tooltips

1. From the View menu, choose Toolbars.

2. In the Toolbars dialog box, select Show ToolTips and choose Close.

To create a new toolbar, you first create an empty toolbar, and then drag buttons onto the new toolbar from the Customize Toolbars dialog box or from other toolbars. 

To create a toolbar

1. From the View menu, choose Toolbars.

2. In the Toolbars dialog box, choose New.

3. In the New Toolbar dialog box, specify a name for the toolbar.

4. Under Menu Group, specify the menu group to associate with the toolbar.

· The Toolbars dialog box lists all available toolbars. The menu group determines the file to which your toolbar configuration is saved. 

5. Choose OK.

6. In the Toolbars dialog box, choose Close.

· The new, empty toolbar is displayed. You can now add tools to the toolbar. You can also create new toolbars by dragging a toolbar button from the Customize Toolbars dialog box to the AutoCAD window. A new toolbar is displayed with the button.

Flyouts:

· A flyout is a set of buttons nested under a single flyout button on a toolbar. Flyout buttons are defined by a black triangle in the lower-right corner. To create a flyout, you create the flyout button and associate an existing toolbar with it.

To create a flyout

1. From the View menu, choose Toolbars.

2. In the Toolbars dialog box, choose Customize.

3. In the Customize Toolbars dialog box under Categories, select Custom.

4. Drag the flyout icon (a small black triangle) from the Customize Toolbars dialog box to the destination toolbar.

If you don't have a destination toolbar, AutoCAD creates one when you drop the button anywhere except on another toolbar.

5. Right-click the newly created flyout button.

6. In the Flyout Properties dialog box under Associated Toolbar, select the toolbar to associate with the flyout.

NOTE Always create a toolbar before you create a flyout. If you don't associate a toolbar with the flyout button, AutoCAD issues a warning beep when you select the flyout button.

7. Under Button Icon, select an icon for the flyout. 

· You can modify the icon by choosing Edit to display the Button Editor. See the following section, "Editing Button Icons."

8. To display the icon you specified, do one of the following:

· Select Show This Button's Icon: Displays the icon you specified for the flyout. When you click the flyout, AutoCAD starts the command represented by the first button on the toolbar you associated with this flyout.

· Clear Show This Button's Icon: Displays the first button on the toolbar you associated with this flyout until you use a different button from the flyout, when that button is displayed.

9. Choose Apply, and then close the dialog boxes.

… Now your are Familiar with AutoCad 2000 Environment and Ready to jump to the next lesson!


With my Best Wishes

AutoCad 2000 Options Dialog Box








PAGE  
1/10

June 2002                                                                                                           Eng. Mohamed Salah Ebeida


